Frustration on Pimax 5k+

Dear All

One month after receiving my pimax 5K+, I cannot use with my only and favourite game PREPAR3D
I have written to the support and no answer. Above all, this is a problem they had solved in the pimax4K in less than one week. I do not understand this lack of support from Pimax on something that is simple.
How do you think I can get to the support team ? I have a now useless pimax 5k+ waiting for a PITOOL software update


@anon74848233 @Sean.Huang

if its simple do it yourself as they are busy and on holiday at the moment

1 Like

Might also be an issue on game dev. Maybe @yanfeng might know some setup ideas.

It is a problem with Pimax mesh. As I said the problem was solved with Piplay.
I am not a dev so it will be difficult for me to solve that issue.

My suggestion: don’t use Prepar3d. The engine is too dated to handle VR even on the first gen headsets, not to mention Pimax.

I’d suggest you try Aerofly FS 2. Pimax runs butter smooth with everything maxed out, and now we have smart smooth which can make it even less demanding.

If you think FS 2 is too amateurish, there is X-plane 11. It’s not as smooth as FS 2, but still much better than Prepar3d, and there vulcan is coming this year which will greatly improve the performance.