FPS terrible in v132. Any fix?

I’m running the v132 beta and Creed now works for the first time without the double image (hooray!). However, it runs at 41 fps. Beatsaber does the same thing. I have an 8700K CPU, 2080TI card, DD4-3600hz RAM, and an SSD, so it doesn’t get much faster.

I’ve tried small FOV, .75 rendering quality, lowering the Steam SS to about 75%, turning parallel projections off, and rebooting the HMD and the computer, but the FPS according to the FPSvr app stays about the same at 41, which is weird. I also tried uninstalling and reinstalling Pitool.

Beatsaber still manages to play with some blur. However, the tracking in Creed is very sluggish and I notice there’s some wavy distortion when I’m looking at the menus or straight lines in this game.

And which forum is the best place to post these kind of issues? I know contacting support directly is a complete waste of time as I’ve tried 7-8 times since January and have yet to get a helpful response (and generally no response at all).

Personally, I’m amazed that everyone is not furious at Pimax. I own two units (a business edition and a 5K Plus) and have yet been able to simply play a game without fiddling with settings for 30 minutes to an hour and screaming at the thing. On the rare occasion a game works, the FOV is amazing. However, the majority of the time, it does not work with a rotating array of random glitches.

Any help would be greatly appreciated as I’d really like for it to work.


You are not running the beta but latest release of Pitool
If the last version of Pitool worked better for you then uninstall and use the that version instead.

I have not read elsewhere a similar complaint and the issue seems quite odd if nothing changes you fps.
Do you have the latest firmware installed on your HMD and latest graphic drivers for your GPU?
Do none VR games function as expected?
Do you see a resolution difference when changing the SS settings?
Do you have V-sinc disabled in Nvidia control panel?


Thanks for your response, Dan!

None of the previous versions have worked very well, thus why I upgraded again.
PiTool says I have the latest firmware (ends in .212).
I tested more VR games, and Labs, Holopoint Chronicle, and A-10 seemed to work fine.
I downloaded the latest nVidia driver this morning. Also updated the BIOS on my computer.
I don’t generally notice a huge difference when I change SS settings, but I haven’t done careful comparisons.
V-Sync was set to “3D Program settings” which I think sets it individually by game. So I changed the global setting to Off. I assume that’s what we want?

Creed still runs at 41 FPS no matter what I try it seems, but there’s so many settings, it’s hard to say if I’m missing the right combination.

Beatsaber tolerates Normal POV and render at 1.0 (hooray!), but falls apart if SS is set to 100%. So, I set the global application resolution to 100% and the BeatSaber specific resolution to 50%. That returns FPS to about 82. However, ever since using the Pimax, the lightsaber blurs when arcing through the air. Does everybody get that, or is it just me?

On other games like Labs, Holopoint Chronicles, and A-10, FPS is great with SS = 100%.

I got Raw Data to work by turning on Parallel Projections and turning off hidden mask. SS is 78% for this game as I had performance issues in the past. The challenge is setting everything correctly the next time I or someone wants to play. Is Pimax ever going to add custom game profiles? Crowd sourced profiles would make a LOT of sense if they can’t simply auto-detect what settings you need 95% of the time (the ideal scenario).

1 Like

Yes you want V sinc off but if you use it for other non VR games then you can set it just for that program in Nvidia control panel.

If it works okay with other VR titles then it must be a specific software issue.
Ensure the games that do not work have V sync disabled in the game options in case it overrides Nvidia.

I might have suggested the res is too high but you say you get the same fps with very low settings?
If you had a Pimax 8K and not 5K+ then the 40 fps lock would be suspiciously inline with brainwarp being half of 80.
Have you tried at lower refresh rates such as 72Mhz to se if the fps changes to 36 int hose games, that might give a clue at least.

As I say you can contact support by raising a ticket on their official site but as far as I know there are no issues with beatsaber but creed I don’t really know. (MRTV playingbeatsabre with Pimax 5K+ 90fps)

If the tracking seems sluggish in creed then that does sound like the game is struggling to render or may just be an issue with that game.
Some games do not require Parallel projection on and may show distortion with it on while others require it on to display correctly.
Ensure parallel projection is off in Pitool and compatible with Vive games on.
Launch both steam VR and your games through Pitool
Ensure you are changing steam rendering under the steamVR settings/Video tab and not the applications tab.
I know it works universally under the video tab but the applications tab may be a good way of setting individual games rendering target (not tested it yet)
Yes Pimax do need a way for us to store profiles as different profiles suit different games.

1 Like

reinstall FPSVr app, and check values in steam vr

1 Like

I played Skyrim VR today with SS turned up to 122%. It seemed to perform fine with no stuttering or slow tracking, but FPSVR tool reports 82 FPS and then other times, 41 FPS. If this is brainwarping, can you explain what’s going on?

The weird thing is that in OpenVR app settings, it shows statistics like lost frames. However, it showed zero lost frames when I checked it after playing. I would not expect brainwarping or whatever to cut the FPS in half if we’re not actually losing frames. Is there a glitch going on?

Lastly, I noticed some weird artifacts around the edge of the lense in Skyrim with Normal FOV. Is that typical?

I have been running the Oculus store Creed on 129 just fine. Picked it up for $10 when it was on sale.

Yes it can only be brainwarp.
When the fps drops below refresh rate of HMD then brainwarp will kick in.
When brainwarp is active it should show half the refresh rate the HMD is set at.
If you are sometimes getting just over 80 and other times just over 40 that suggests that you are right ont he limit and because fps in game schanges depending on the amount of things being rendered the game will drop to below 80 fps on occasion at which point brainwarp will kick in and display 40 fps regardless of whether the game is capable of 78fps or whatever below 80.

What is odd is that I thought you had pimax 5K+ and not pimax 8K and the 5k+ renders at default 90 fps and 45 fps if brainwarp kicks in.

If you find you can notice the transitions between brainwarp kicking in and turning back off then you might be better either lowering settings so that you don’t drop below 80 fps or raising them so that you are always below 80fps.
I know this sounds a little counter intuitive but if are fine with brainwarp then you may as well push the settings as high as you can go before they drop below half you HMD refresh rate and just have brainwarp do the work for you.

It can also be a good idea to set max fps in game to one frame above brainwarp fps (half hmd refresh rate) to give a smooth experience but this will require that the settings you have for teh game can maintain a minimum of the max fps you set. ie HMD is 80mghz. Brainwarp is 40 fps. max fps = 42 (always use brainwarp) min fps is >=42

Graphic artifacts can vary with FOV and game.
If you are seeing them then maybe try altering some pitool settings one at a time and retesting to see if they disappear.
It may be that some games are not well optimised with the Pimax distortion algorithm as yet and that is a work in progress.
If all else fails and it is still distracting then try small FOV.
I know that Google Earth always caused distortion and visual artifacts for me unfortunately but other apps look great.

I turned Smoothing off as it drags performance down on Skyrim and Beatsaber. On Skyrim, I reduced SS to 100%, Render to 1.0, FOV to Small, and Hz to 72. It now stays at 72 FPS most all the time.

On Beatsaber, the game had set its graphical/rendering enhancement to 1.8. I changed it to 1.0 and graphics look great and FPS issues are gone.

I haven’t noticed artifacts lately with the Small FOV. Maybe I’ll re-test Normal again, but there’s not a huge visual difference between Normal and Small in my opinion.

Thanks for your help!

FYI, Creed still won’t play above about 40 FPS with smoothing off. I still need a solution to that if anyone has one. When smoothing is on, it still seems sluggish when I swing my arms and is just not a good experience.

Cool, whatever gives you the best experience.
I’m just saying that if you don’t mind brain warp then 36fps at much higher res on same FOV can give a very nice image.
For example instead of wanting 72fps you can just worry about getting 36 fps with brainwarp which allows you to supersample,
For games like beat sabre this probably isn’t a great idea but for sitting experiences like sims where latency isn’t really an issue it can be a good way of getting a very nice image with negligible SDE

I have similar setup to OP 8700K 2080ti and I get poor performance with my 5k+

The framtimes are good but I still get constant fps dips and fluctuation. GPU utilization never gets close to max - on a rare occasion maybe to 80% but mostly hovers around 65%. This with fps drops while frametimes remain below 11ms – frame times can be as low as 8-9 and still get fps drops.

Im pretty sure there is an issue with the pimax software. This is also noted by sweviver regarding gpu utilization.

The issue seems worse with the latest beta pitool - which I need for index controllers.

Waiting for a new pitool version hoping it has a fix

1 Like