(Fixed) 3090 - 8KX panels off in 90 Hz mode investigation + working DP extension cable options (3/4/5m)

TLDR; Closed beta/alpha 90Hz firmware + Supra DisplayPort cables and Lindy 38415 DP repeater works perfectly

Quote from @PimaxUSA - I was one of 17 who had issues with the first firmware and have no issues with the latest build I received:

Split from another topic about occasional black outs in 90Hz mode. This topic is about 90Hz mode causing the panels to be completely off from the start but everything else working (headset is tracked - seen in Pimax Experience window).

Original post:
I have just ordered a new (standard) cable after finding out that I can make the headset completely power of by moving the cable near the plug at the headset end (and it stays off until I move it again).


I dont quite understand - what do you mean? Which cable did you move near the headset side?

I tried gently wiggling the cable that connects to the headset near where it plugs into the headset (and also tried reseating it).

It’s detachable but it doesn’t look like it at first glance.

1 Like

Oh you mean you have a loose connection.


Or faulty cable, or faulty connector that can result in a loose connection.


That’s what I’m hoping for of course and why I just ordered a new cable… :+1:

Really hoping it’s not the socket inside the headset.

Anyway, yes a loose connection somewhere (probably in the cable).


Short update on the new cable: Still black panels (off) when choosing 90Hz but tracking fine (as can be seen in PE) and I’m unsure if there might be a loose connection in the headset as I can still make it power off/on completely by wiggling the cable gently (don’t want to keep doing it though as it seems to work better than the old cable).


mine does this sometimes, black panels but tracking when starting the HMD, not sure if it’s related to 90Hz since I’m not running any other Hz than 90.

What brightness settings are you using ?

Edit: Maybe my issue is more so the Power saving that seems to be partly implemented. Only turning the panels ON when moving the HMD when booting in 90Hz ?


I’m “normally” only on 45 but have recently begun using 92 on 75Hz.

I did think it might be related to that so I tried going as low as 30 to verify, but no dice.

Yeah, could be. It does seem pretty weird that they’re consistently off when switching to 90Hz.

Like some kind of a bug, but what do I know? :slight_smile:


With 90Hz on my 8KX the panels are always off when it is static and the led is red, but the tracking is always active. When I move it a little it takes a few seconds to turn on the panels and turn to green LED, so at first I also thought that the connection was failing. But I realized that it always reproduces, and if you leave static the HMD turns off at 45sec. more to or less. Of course in 75hz mode it doesn’t behave like this.

So perhaps moving the cable and turning on the panels could be that rather by the simple movement of the HMD it turns on but as it takes a while you think it is due to a bad connection.



I’ve been giving it the “Pimax Shuffle” when using a single basestation to get it tracked initially so unless it takes minutes to get out of sleep mode, that’s not it.

But maybe it’s just not getting out of sleep mode for some reason?

Are the panels completely off (no backlight) when in sleep mode in 90Hz?


Yes, the panels are completely off


Might just be a bug causing the headset to never leave sleep mode then?

1 Like

I would be inclined to think so, at least the part that should turn ON the screens.
If only we could turn off this feature completely, we could eliminate this as the culprit.


There might be a hidden option.

@PimaxUSA could You check with the developers if it’s possible to disable the seemingly enforced sleep mode on 90 Hz completely via a config file option?

EDIT: Doesn’t seem like it has anything to do with sleep mode sadly.

If not, maybe it’s worth a try to compile the firmware with it disabled to rule out that being the issue?

I’d gladly verify it of course… :+1:

Come to think about it, I actually recall having issues with the sleep mode on the 5K+ too (I disabled it as once entered I couldn’t make it leave it again).

Not sure if it was completely the same issue, but I guess it’s worth a try, right?


Ive had this similar issue also when i leave the headset alone for 2-3 minutes and come back and cant get the headset to wake up. But this is very different than the blackouts.


From what I recall I think there is something in the Jsom file of sorts. But yeah may require a deeper level.

1 Like

Yeah, sorry about that.

Will try to see if I can split into new topic.

EDIT: Done… :wink:

1 Like

Another important note on this issue is that I have the exact same graphics card as @MrAhlefeld (Inno3D iCHILL Frostbite RTX 3090) and he does not have the same issue.

I no longer think it’s a power issue either as I have tried with the secondary USB connected to a USB wall charger, and also have my USB 3 extension cable powered now.

Also tried without extension cables of course and tried more or less all variations of connecting the DP and USB plugs to various ports.

I have never had 90 Hz working. Not even once.

I’m considering trying to install Windows 10 on a spare SSD to try it on a completely clean install.


By the way, there was a post a while ago that i found last week that shows how to change the standby timer in the steamVR Json files. I’ll try to find it.