Fix for VR frame drops and stutters on NVIDIA cards

Great! Thanks for the pin! :slight_smile:

5 Likes

Perfect! Finally after all this time Nvidia fixes this major issue. Now I think I will play VR more. Lately I’ve been so addicted to Call of Duty Warzone and Cold War that I get too lazy to put on a VR headset lol.

6 Likes

Should be pointed out the issue is still there if you are running monitoring software like fpsvr or afterburner

9 Likes

This is a hotfix but you cannot use precision x1, afterburner, rivatuner, fpsvr, etc - which makes it a bit worthless for the overclockers. If you use any of these apps, skip this until the full fix is done.

7 Likes

And this is exactly why I love the Pimax community; everyone’s looking out for each other. Thank you!

7 Likes

Do you have any idea why GPU monitoring tools don’t work with the fix?
I use FPSVR alot.

Also for anyone not aware of what this issue actually is and want to see what a working driver should look like watch this video

1 Like

Or if they actually do not work with it. The last such hotfix from NVIDIA did nothing for me. I am thinking these hotfixes may actually resolve conflicts with specific background software that may be installed, while possibly creating new conflicts. As complicated as the chain of software/HDL stuff from CPU to USB controller stuff is these days, anything is possible.

So, maybe if you don’t have the specific software that may have a conflict, and if you have other software, these hotfixes could do more harm than good?

In any case, the fact is NVIDIA driver versions have been much more likely to have regressions over the past few years. Used to be that regressions basically didn’t happen. I guess their software development team is getting overworked, or the code is getting too complicated.

NVIDIA could of course just open source their drivers.

I always thought

“How is it that nVidia always seems to have drivers optimized for the latest games when they come out?”

More like tweaking things to make the games that people are paying attention to work well and regressing all previous optimizations hoping we wont notice.

This explains why at launch the 3070 seems to be slightly behind the 2080Ti in terms of performance but try again and run the same benchmark in a year and suddenly the 2080Ti is 10% behind.

Im afraid maybe VR just got lost in the shuffle last may and they are only getting around to fixing it now.

It’s impossible for nVidia to optimize for everything right? Either that or their drivers are designed to be unoptimized.

From what I read a while back, NVIDIA used to be working around bugs in game engines, like rewriting a web browser for web pages that didn’t use proper ‘<html>’ tags. That is why every release of their drivers would bring 40% improvements to most games. That stopped happening shortly after Crysis, when the big game engines (Unity, CryEngine, Unreal) became dominant and most people stopped making their own.

Now, NVIDIA seems to be too busy trying to make developers use RTX, CUDA, and such that you can only get from them. Instead of like OpenCL.

Leaving real performance on both the hardware and software side to languish badly.

Anyway, back on topic. My point is we should probably start thinking of NVIDIA drivers in terms of this version may or may not help with whatever combination of installed software/hardware we may have.

2 Likes

Since I’ve got my 8K-X, I am so addicted to VR I have never been before. Since September last year, when I got mine, I am playing 90% VR only, just interrupting for a couple of event-related matches in World of Warships :laughing:

On my new build and Windows installation, I already installed also a couple of games I’d like to play or finish, such as

  • Spellforce 2 Faith in Destiny
  • Bioshock Infinite
  • Frostpunkt
  • Grim Dawn
  • Star Wars Battlefront 2

… but I simply can’t resist the wish to fulfill either the next contract in ETS2/ATS or to do a space flight in Elite Dangerous… :joy:

5 Likes

Bioshock Infinite is one of those DirectVR supported games in Vorpx and looks as good as native. The whole series actually, plus Dishonored.

1 Like

It’s so hard as humans to resist the urge to simply click update whenever that update notification happens.

My OCD just can’t seem to ignore that it’s there. As long as I know there is a more recent version the FOMO kicks in. :sweat_smile:

I should know by know with nVidia and Pimax later isn’t always better. It just means it’s less tested.

2 Likes

:rofl::joy::rofl: Never. A watercooled 380w 2080Ti is 10% behind a 400w 3080oc :joy:

i’m talking stock. Not gamer nexus nitrogen cooled frankenGPUs. :stuck_out_tongue_closed_eyes:

Then only the Superslow 260W Founders and Blower Edition
Every not FE is 10-25% faster on Stock :crazy_face:

An official driver update has been released:

But it still requires that monitoring software be turned off.

2 Likes

They’ve fixed nothing

1 Like

Just to clarify - they have fixed it, partially as per dmel642 said above. Read it again - they fixed it without hardware monitoring running in the background. They are still working on another fix for when monitoring software is being used.

1 Like

sorry, i just saw this

1 Like

i need 4K Pimax Tech Support pls!

Pimax 4K VR not recording bigscreen environment (movie theater)

Nvidia ShadowPlay recording “SteamVR” worked when i had 4K Pimax HDMI plugged into RTX 3080 with TV HDMI plugged into onboard graphics (motherboard)

However the FPS (frames per second) was only 30 FPS and i need 60 FPS for my youtube channel

So i went to BestBuy and got a DisplayPort to HDMI Adapter

, i have Pimax 4K HDMI plugged directly (no adapter) into RTX 3080 Graphics Card With TV HDMI plugged into RTX 3080 through DisplayPort to HDMI Adapter.

Now when i record with Nvidia ShadowPlay, it only records the “Desktop”, instead of showing
“Theater Environment”. pls i need this for my youtube channel & for myself.

After i removed the Display Port Adapter from TV HDMI & placed the the TV HDMI into Motherboard Onboard Graphics, The Nvidia ShadowPlay recorded “Steam VR” (But only 30 fps again) Main concern (Recording Steam VR 60 fps or higher) above!

it is also stuck on Pi Tool Update Firmware everytime i click. Pimax 4K keeps appearing connected & disconnected every 2-5 mins. i have Pimax 4K, RTX 3080 Graphics Card intel Core i7-8700 CPU @ 3.20GHz 64Gb RAM 580Gb Optane with 65" 4k TV 240 hz