Fix for 5k Plus solid red light unrecognized issue

I recently bought 2 Vive lighthouses and a controller and while attempting to set them up I ran into an issue where the Pitool did not even show the Pair Controller button. While trying to resolve this following many of the flash firmware ideas and other things the headset went dead basically and would only show a solid red light and Pitool said unrecognized. After trying everything I finally tried uninstalling Pitool then deleting the driver in USB section of Device Manager. Next I deleted all mention of Pimax and Piservice in the Windows registry using regedit. Then I reinstalled Pitool and turned on the 5k plus hmd and poof all the room setup and controller pairing and everything synced up and worked perfectly. Then I could start SteamVR and it also recognized everything properly. So my suggestion to anyone else having this solid red light issue is to try deleting the registry entries and reinstall. Letme know if this helps anyone else because this frustrated me for about 3 days I feel your pain


Can you post your system setup please? With pitool version.

Backer or pre order?

Windows 10 Pro
MSI Z370 MB Intel i7 8700 3.70 ghz CPU 32gig
Nvidia 1080 GTX ti 32 gig
PiTool ver.

1 Like

Are running Latest Nvidia driver?

Yes latest driver just a few days ago and was before issue occurred though I do not believe the Nvidia driver was the cause. The hmd was working fine before and after the latest Nvidia driver update. I suspect it was because I had already ran the initial room setup for no lighthouses so when I finally bought 2 Pitool did not offer to set them up. I think some residual setup info was contained in the registry entries so wiping those allowed Pitool to allow reinitializing like it was first time setup. At any rate I have 2 functioning Vive lighthouses now and Vive wands both in Pitool and Steamvr. I also have a Oculus Rift and so for not having the best luck running Oculus titles even though they show up in My Games on Pitool. Some work some don’t but that’s why I have the Oculus also.