Everspace Buggy AF

I have tried for 2 days now , every possible setting in PiTool and steamVR and cannot get everspace to run at all without crashing with memory errors and choppy framerates.

Can anyone confirm if this game works on their pimax or not?

1 Like

Everspace on sale atm? Think it’s cheap. I recall I think someone reporting low textures before.

Will maybe check & purchase.

Noticed Steam is lumping re7 in VR section; has it finally had pcvr update?

Does it work on any other HMD’s besides Pimax. I bought Derail Valley and it was choppy and had various glitches. I went to Discord and found out it was across all platforms and HMD’s. SO it wasnt just my Pimax…

1 Like

Dunno about the current build but I played it on my Vive after release and it was fine. Maybe I should fire it up once again. It is a great game!

1 Like

Several players complain about the game not working or working badly in the Steam discussion forum, even with other headsets.

Unfortunately, no.

1 Like

I purchased it, and it worked except for some problems with the quests visuals, but I request the refund because I do not like the controls

1 Like

Figures there still keeping us pcvr folk out grrr… Lol

It works well on my Rift. But on other headsets than rift or vive the hud has many issues. It works on my Pimax 5k+ but you cannot jumb to the second sector because of these hud problems. Very sad, because it is a great game with awesome visuals

1 Like

What is your pitool settings?

Just tried Everspace & it’s a jittery mess spiking the crap out of cpu & gpu.

Everspace tried on default epic & low setting.

Pitool 144
Render x1 FoV Normal
Pp on

System R7 2700x 16g ddr4 3200
1080ti latest game driver
Steamvr Non Beta on Auto.

Okay hit some pay dirt!

Launch Game in VR for Oculus plays relatively nice.

I launched from Steam Desktop & choose Oculus VR. It complained wrong headset but launched!

May need to tell Windows to use headset Audio. (No sound in test)

@Thoemse haven’t tested Vive Mode.
@Schadows thanks for Oculus tip.

1 Like

I run this on my rift and its smooth as butter.

1 Like

I thought about doing this, but I tried to do the steam_appid.txt thing and add it to pitool and it didnt work.

So how do you do this exactly. I assume no steamVR running and then you just choose oculus mode?

I thought you needed that steam_appid.txt file to launch oculus games?

1 Like

With headset connected (pitool running)

On your desktop goto your library use the drop down arrow I think & choose to launch Oculus version.

If not there right click in library list. But sure it was in drop down. Steamvr may need to be running to have option. Have to try it again.

Option should look something like
Play In VR
Play VR Oculus

Everspace has oculus launch option.


OMG it worked. :smiling_face_with_three_hearts:

Crazy. Makes me wonder now how many other games can be launched in oculus mode.

Game doesn’t play perfectly though.
So far i find it works best with the following
Game Quality: low and
Smart smoothing : off.
Parallel projections: off
FrameRate: 90Hz


if anyone manages to jump into the second sector, please let me know. I really like the game. Too bad there is such a problem with the Hud.

1 Like

Always a pleasure to help … Even when it’s not me who helped ;p

1 Like

whats this hud problem you speak of?


all symbols of the hud appear only on the edge. as soon as you try to fly on it it disappears. This makes it more difficult to focus enemys or pick up boxes. But to jump to the next sector you have to fly a few seconds directly to the circle symbol. Since this also disappears it is impossible to get to the next sector. I noticed this behavior with the Pimax 4k and 5k+. Everything works perfectly with the Rift

1 Like

Here is another one with the same problem:

1 Like

My bad thought you mentioned it played well on rift.