Catalyst at 10.00 before starting VR works perfectly, don't touch it once SteamVR has started, 100% gpu usage and perfect image

Try running catalyst at 10.00 in pitool before you launch steamvr, just tested it, don’t touch it, for me it works perfectly, 100% usage.
As soon as i change it in game it goes back to the horrible image and need to restart to fix it.
I tested in onward, SteamVr home and beat saber, all worked perfectly and amazing frame rate.

Onward before:
SS - 100%
Catalyst - 0.00
GPU usage avg 60%
Fps avg 85

Onward after:
SS - 150%
Catalyst - 10.00
GPU usage avg 95%
Fps avg 120

Ill try to list all my specs, can others try this to see if they get similar results because this has totally transformed the pimax headset for me.

CPU: i7 8700k @ 5.2ghz (water cooled)
GPU: RTX 2080 @ 2.1ghz (water cooled)
RAM: 32gb Corsair platinum @ 3600mhz
SSD: 2tb samsung 860 evo
Windows 10 pro update 2004

Pimax 5k+
Firmware v2.1.255.264
Pitool v1.0.1.261
Pitool settings:
Normal fov
render quality 1
Parallel projections on
Hidden area mask on
smart smoothing off
FFR off


yes, it works, but also requires a lot of CPU power. So it doesn’t work everywhere.

test it with XPlane. Rarely seen so many beautiful single pictures. :joy:

For DCS it works nice, except in the channel map. To much objects.


That is a very interesting finding. I think I’ll do some testing tonight.

1 Like

It this in PiTools? under Gen, HMD, or games?
Right now I have my Rift S plugged in. Use the 8K+

It’s in PiTool / Games.

1 Like

My testing determined that setting Catalyst to anything above 0.0 causes issues for me. I only tested Elite D, since that’s my primary VR game. I saw lots of stuttering. Oddly, at low levels of Catalyst, there was no stuttering in VR as long as the game mirror window on my monitor did NOT have focus. Of course, you can’t play the game without keyboard control and as soon as the mirror window was activated (to become the primary window with input focus) the stuttering started.

I decided to roll-back PiTool from 261 to 253, which a lot of people say has good performance, but I only got 12 FPS! I probably need to flash the headset to match, but I think I’m just going to reinstall 261.

All in all, it’s been a disappointment.


I also noticed that it doesn’t like parallel projection at all.
xp11 5-14 FPS

1 Like

Did you make sure to set it and not change it while the game was loaded? For me changing it then even changing it back to 10.00 breaks it and I needed to restart steamvr.
There’s definitely a bug in Steamvr or PiTool causing this behaviour

1 Like

I thought this was interesting, so I played around a bit in the 3 titles I use most; No Man’s Sky, Skyrim VR and Project Cars 2.
My results were mixed.
AMD ryzen 7 3700X,
48 gig of DDR4,
Nvidia GTX 2080ti,
Pimax 8k

I started with NMS, SS at 1, Catalyst set to 10.
In space I was getting better frame rates (above 60fps) than usual with very little of the jerky flickering the Catalyst usually brings.
Landing on a planet got the jerky stuttering flickers, and, as it always does in NMS, the framerate dropped on planet.
So I experimented a little, because the in-space results were pretty impressive.
I dropped the catalyst to 4.75, and it was still pretty stuttery.
On a hunch I then enabled Smart Smoothing and restarted, leaving Catalyst at 4.75 and SS at 1.
This time, I got a solid 40fps on planet and in space, and no flickering at all, with one exception.
When turning or jumping fast, the very edges of the life and shield hud blur a little.
But overall, this is the best I’ve ever had NMS running on the Pimax.
Conclusion: a success.

Skyrim VR, SS1, Catalyst 10:
Not good, very jerky/flickery/stuttery. Framerates actually worse than I’d normally get.
Dialled catalyst down to 4.75, enabled smart smoothing, still too much jerkiness and no really good framerate gains.
Turned catalyst off, disabled smart smoothing, restarted, and got my old 40+ fps back.
Conclusion, failure so far.

Project cars 2.
SS1 catalyst 10: very jerky, no real framerate gains.
Catalyst 4.75 and smart smoothing on: still too much jerkiness, but I did notice if the framerate could get above 40fps steadily the jerkiness almost disappeared.
I turned down a few graphical options to improve the framerate and it was less jerky.
But I was getting next to no FPS gain in return for the lower settings and still some flickery stutters, so:
Conclusion, failure so far.

But if only for my gains in NMS this does seem interesting.
I will play around a bit more when I have time.
I wonder if the jerkiness of catalyst being seemingly removed bt smart smoothing tells us anything useful, or if I’m just misinterpreting something and barking up the wrong tree?

1 Like

I noticed this exact same behavior, silky smooth as long as the window was out of focus.

I did some more testing and if I wasn’t hitting the refresh rate I got a small amount of stuttering, but still getting around 95% GPU usage, aslong as I was getting 120fps then it was perfect.
But still, changing catalyst while the game was running caused the horrible image judder to return at any setting apart from 0.

I’ll test Pcars2 and NMS in a bit, but from my testing if I wasn’t hitting the frame rate cap, either the refresh rate or half with smart smoothing I had some stutter.
If you only get around 40 fps in Pcars2 then maybe try 72hz with smart smoothing on and try catalyst 10.00 and see what happens when you hit the frame limit.

Just curious, does your NMS stutter during the intro when it’s leading you to a random planet?

Yes a bit during the “fly through stars” intro, but once it “settles down” to 80fps in that bit the stutter is gone.
I just went back in to confirm that on Cat 10 I still get stutter on-planet even with smart smoothing on, going back to Cat @4.5 and I’m back to a solid 40fps (the smart smoothing I guess).
This all supports the idea of Bradliam1 that there is a threshhold of framerate where the stuttering doesnt apply.
Which is a bit counter-intuitive as the catalyst is supposed to boost framerates anyway, which it does seem to do if the game and system can meet certain conditions, maybe. Perhaps.
More testing needed, but NMS just did a 5 gig update and now my precious mods dont work, so thats top priority for me now.

I have checked @SweViver youtube 8K X video of 29 jan 2020
probably made with Pitool 254a

Pimax 8K X Benchmark: VR Performance tested in 20 Games and Simulators - YouTube

At beginning Onward has 75% GPU utilization
At the end is 49% GPU utilization

I have compared with index

Gpu utilization in the game onward goes down when you take the gun and aim

Index Gpu utilization seems to be better at me : i7 8700/1080

With catalyst at 10.00 I get 95% GPU usage almost consistently in onward and 120fps with the settings at low, 150% SS. It could be due to have an RTX 2080 but I can’t imagine the GPU usage would be down to that, could be CPU?

1 Like

Can someone else test what I’ve found by following these steps.

  • Turn catalyst to 10.00 while steamVr is not running
  • Load an easy to run game such as beat saber
  • Make sure you are getting your frame rate cap (90fps for 90hz etc)
  • Check GPU usage and any signs of stuttering.
  • Raise the supersampling/graphics so that your frame rate drops below the cap without smart smoothing and then check for stuttering
  • Change your supersampling back to what you had prior then while the game is still open, change the catalyst to anything, apply, then change back to 10 then check for stuttering
1 Like

I know previously any changes I made to catalyst without restarting pretty much everything did not actually get applied. The slider moved, but nothing happened. They may have fixed this since, of course.

It definitely changes, you need to press apply though

Yes. The strangest part was that the stuttering was much improved when the mirror window was NOT active. Generally, Windows gives more CPU time to the active window / app, which (as a programmer) I thought would make VR less likely to stutter (not more).