Can someone explain this anomaly

Steam reports 4003x2470 ss 22%
Fpsvr reports 5116x3156 ss 100%

1 Like

Someone reported on this forum that the resolution numbers aren’t accurate, when PiTools quality is set higher than 1. I can’t verify it, since I don’t have a headset yet.

1 Like

What fpsVR says (I am not saying it is correct) is that you set your SteamVR global override to 100% and your SteamVR Home application override to 156%. The former seems not to be true (as your SteamVR UI shows, the global override should be at 22% and not 100%).

I would probably put more trust into SteamVR UI than into fpsVR. Though could you check what is your SteamVR Home SS setting (if you have changed it)?

Apart from all that, there is/was (someone reported it should be fixed in the new SteamVR version) a limit on the recommended render target resolution OpenVR reports to the application, regardless what SteamVR UI shows (and that limit is for Normal FOV 4096x3499). Once the recommended resolution reaches these numbers, increasing SS factor anywhere in SteamVR UI (or rendering quality in PiTootl) has no effect.

1 Like

Haven’t changed steamvr application settings. So it’s still at 100%. And I’m running Large FOV

1 Like

Ok I worked it out. Seems there is a bug with steamvr. If I set steamvr to manual and then set ss 20% it will default back to 100%. You can try this by just having the settings screen displayed of steamvr. Put ss to 20% using desktop view in steamvr home. Then hit your vive controller home button to get rid of steam home. Then hit it again and look at your steamvr ss. Back to 100% ss. If you put steam ss to 22% this does not happen. So what I thinking happens if you have steam ss set to auto and it hit 20% it will default back to 100%. So I suggest no one use auto steamvr ss or you will be stuck at 100%. Just set it to pitool 2.0 and steamvr manual 22% so it won’t hit 100% on you.

2 Likes

Yes, that does seem to be the best approach for now.

@PimaxUSA suggested in one of his interviews, that a higher PiTool rendering target is to be preferred as it ‘does a lot more than just increase the resolution’ or something along those lines.

2 Likes

This does not seem right to me, as I never had problem with manual override setting in SteamVR. Are you on SteamVR beta?

The way the auto setting works is that OpenVR, when started, runs a short GPU benchmark and based on the results adjusts the res so the overall pixel bandwidth corresponds to your GPU performance and the frame time limit (~ 11 ms for 90Hz refresh).

When you change PiTool setting, you increase the resolution the Pimax reports to OpenVR (i.e. artificially increase the performance requirements). The auto feature in SteamVR is supposed to mitigate that by lowering the SS so the overall bandwidth remains the same and you hit the frame time target.

Also 20% SS seems to be the lowest value you can set in SteamVR, I am not sure what happens when you hit the limiting cases, e.g. the auto bench comes up with suggestion which is even lower than 20% (and cannot be effectively set)?

Anyway, is there any reason why you keep your PiTool setting so high? Be leveling that, you can get far larger range to work on in SteamVR?

1 Like

I heard that too and then I tried to find out what more PiTool does than just setting the res, and did not find anything so far. In fact so far I have only proved that it does not do anything out of ordinary. So I am still skeptical about @PimaxUSA statement.

2 Likes

I’m on the beta. And I have throughly tested it. Looking at fpsvr with steamvr set to auto and pitool at 2.0 also confirms it’s as fpsvr reports 100% steamvr ss which it should be showing 20%. I have also noticed decreased frametimng when 100% is falsely set by steamvr

1 Like

My best guess is it tries to better some artifacts that arise from outside res upping and so it kinda needs its own procedure to adjust some visual weirdness in parallel

1 Like

I think @blitze has reported significant optical differences in some flight sim between PiTool SS vs SteamVR SS.

1 Like

I know. I read it too and I do not know how to explain it. But what I know is that:

  1. If the application uses OpenVR (maybe the apps running without OpenVR behave differently), it gets the recommended render target resolution from OpenVR. It does not have any notion about PiTool, or Vive, etc. How OpenVR figures out this resolution depends on OpenVR and what the headset reports to OpenVR, but in general there is no direct connection between the headset driver and the app.
  2. Once the application chooses the res (it may accept what OpenVR proposes or choose a higher/lower one) it renders the frame and passes it to OpenVR again. Again there is no impact of headset driver on the actual rendering done by the app.
  3. OpenVR takes the frame and either runs it through the compositor (Vive case) or passes it to custom compositor (Pimax case).
  4. Pimax compositor takes the frame, runs pre-lens warp transformation and is done with it. The frame comes in at higher res than is the res of the headset panels so the pre-lens warp transformation includes also downsampling (in a non-liner way to compensate for the lens warp).

There is only so much that Pimax compositor at point 4) can do. It cannot enhance nor improve anything on the image and the goal is it does not do anything unnecessary, because time is money and it is better spent on actual rendering.

I was looking at the rendering pipeline in Elite (which uses parallel projection) trying to see if there is anything out of ordinary happening but did not find anything at all. The images are passed exactly as I described above. Pimax compositor does not rescale the image or anything like that, it just takes the original image rendered by Elite, and transforms it into the headset image.
https://community.openmr.ai/t/is-it-best-to-fix-pitool-at-a-certain-resolution-like-1-75-or-2-0-and-change-steamvr-ss-or-the-opposite-or-are-they-interchangeable/14897/28

4 Likes

I hope they can do something in step 4 that benefits either the 5K+ or 8K, some sharpening or coloring maybe, to get the most out of the specific model’s displays

1 Like

They can, but if they do, there is no reason why it should only happen when PiTool is set 2.0 and not happen when set to 1.0. There is no sensible reason to differentiate.

As I said (and wrote in my other post), if the image resolution coming from the app is the same, I do not see any visible difference on the output which goes into the headset, and, more importantly, I cannot come up with any good reason why there should be any.

3 Likes

I, after extensive testing with the eGPU RTX2080 have come to think it is render resolution targets that are important. Also as pointed out by Decapper - PiTool might be sending wrong render info to SteamVR when moved above the 1 setting.

I have been experimenting with render resolution figures of the following:

PiTool 1.5

SteamVR Video 22%
SteamVR App 110% - gives 2880 render target

SteamVR Vid 52%
SteamVR App 268% - gives 5760 render target

Those based on 1440 which is the res the 5k and 8k headsets use but then it was pointed out that PiTool gives SteamVR a reported render res of 2633 So I played around with that render res target as well with the first being 2633 and the second being 2x

2633 56% App

5266 App 224%

I have also experimented with render targets based on 2160 which is the 8K native panel resolution so render targets of 2160 and 4320 based on
PiTool 1.75
SteamVR Video at 20%
SteamVR App at 50% and 200%

My objectives have been to get a relatively clear image where obects can be discerned from afar in Il2 be it Aircraft at 8km out, moving land vehicles at 1000 Meter Alt (3000 feet) or decent non jagged land marks be they cities or forests when flying at around 1000 to 2000 meters or above.

Ironically with PiTool settings to Normal FOV with no foveate render or smoothing and Render Target of 1, SteamVR gives me a App Render res target of 2761, that when SteamVR Video is set to Auto. This is around what I have been experimenting with and actually, seems quite decent image wise.

1 Like

Steam Vid auto/manual setting is a base setting for cpu. The per ap will say 100%

Just out of curiosity, has anyone tried pitool at 2 with steam ss just about off, say at 20 or something low

1 Like

No, but I am getting frustrated at not being able to consistently dial in same render targets with PiTool and SteamVR.

Those Targets I listed above have now changed and I can not re validate them. Nor can I say dial in a render target with certain PiTool settings and change the FOV and have the vertical render res stay constant. Maybe I have to be more thorough and exit PiTool after every change and then load up each in step. PiTool - SteamVR - SteamVR Settings

What I do know is that there are certain Render Target Resolutions that will perform better on ones hardware even if the target is higher than others. This is possibly due to relationship of either the Render Resolution being sent to the HMD either as a factor of the panel / scaler chip resolution or the resolution as pertaining to what PiTool is broadcasting to SteamVR. Resolutions out side of those factors tend to do worse probably as SS is doing more work on the image to make it decent (as much as it can).

This is my hypothesis anyway.

I wish there was more certainty in this process and documentation but I also understand that this is a work in progress and we are Backers / Guinea Pigs in the process. Maybe with some time things will become more understandable / consistent with regards to settings and render targets. :confounded:

1 Like

Yes, I have done exactly that after picking up the Kevin Henderson interview about prioritizing the use of Pitool. Since doing this setting the Pitool to 2 and SteamVR settings to off. The picture clarity and resolution seem better than ever, but I am on an old Pitool version and have been mainly experimenting with old games on VorpX. So your results may vary.

3 Likes

Thanks @Fresco I’ll give it a try as well.
Did u end up with better frame rates or about the same ?

2 Likes