Audio problems again - please help [FIXED]

@Alex.liu @SweViver @arminelec

On initial installation of the 8KX the volume was acceptable.

A while ago I reported that the audio on the built-in speakers had got “stuck” at a very low level, despite Windows and any in-app audio controls reporting the volume to be at 100%. In that case rebooting the HMD from PiTool seemed to fix it, and I thought (wrongly, perhaps) that this indicated a hardware/firmware problem.

It has happened again, and this time rebooting (plus a complete power down overnight) has not restored the audio to a usable level. It’s not completely off - if I cup my hands over my ears I can just about hear that there is something there.

In attempting to troubleshoot I have noticed a couple of things:

  1. If I switch from “USB Audio” to my normal audio output, either using SteamVR settings or opening the Windows audio icon at the bottom right of the desktop, I can use standard headphones or over-the-ear buds in VR apps, so I have a workaround.

  2. This is strange though. If I start up the HMD and allow Windows to switch output to USB Audio as it normally does, I can play non-VR audio sources (eg an MP3) through the HMD speakers at normal volume! So it is only apps that rely on SteamVR/PiTool that have the issue.

I have tried adjusting volume in Windows, in apps, in SteamVR, and on the HMD.
I have tried rebooting the HMD from PiTool.
I have tried restarting the service from PiTool.
I tried reinstalling PiTool
I tried reverting to PiTool
I tried editing steamvr.settings to remove everything in the “audio” section.
I tried manually selecting USB Audio in SteamVR settings and then setting “volume equalisation” for that driver in Windows settings.
I tried renaming steamvr.vrsettings so that it would create a new one.

Now I’m starting to run out of ideas - any suggestions would be most welcome.


idk but try got to enhancements options & disable them all for you usb audio device, see images:
then you might want to check it & enable back volume equalisation which usually increases volume of the speakers

also try to anylyze the problem WIN10 option by right clicking your audio icon in bottom bar of windows, it got fixed a lot of problems with my mixed audio drivers as I have lot of conflicting ones & it was a constant pain to get Q1 audio work through the link cable


but the best option IMO install free APOEquilizer & boost the volume of your device & disable all the enhancements in windows options

1 Like

Thanks. I already tried manually selecting USB Audio in SteamVR settings and enabling equalisation in Windows settings. That didn’t work.

I should also have pointed out that on first installation of the 8KX the HMD audio was acceptable, so something has changed.

Will try APOEquilizer and see if it helps.

1 Like

if you have other kind of problem I doubt APO will fix it, it helps make sound much loader but if something impact it like software effect, firmware or hardware I doubt it will fix it


at least you know it’s not hardware, coz jack & audio device working ok on Windows stream

1 Like

That’s right. Playing a non-VR source like VLC Player while the HMD and USB Audio output are active gives acceptable volume through the HMD headsets.

1 Like

There is a volume button in the bottom right of the SteamVR dashboard, between standing position reset, and settings.

I could be wrong, but I believe if you manually delete SteamVR’s audio settings, the volume defaults to a “safe” level.


That was already set to 100%, but thanks for trying to help!

1 Like

Did you try to move/remove/unplug the audio jack/wire? Bad connection can lead to weak sound level.

1 Like

That can’t be it since it works with other sources:


oh yeah ok sorry.
Hmm weird


Update: I spent a couple of hours today looking at all the multiple settings and json files that Steam, PiTool and Pimax Experience scatter around the place, to see if I could find an audio level setting. Without success.

I’ve also noticed that the sound effects within SteamVR that play when you select a button, for instance, are audible. It’s just in apps that the audio is unusably low. It was not like this until a couple of days ago, but something has changed.

For the time being I have given up and have told SteamVR to use another audio output, so I can use over-the-ear earbuds instead of the built-in HMD audio. In fact they have better sound quality anyway, it’s just a bit less convenient.


Have you tried uninstalling/reinstalling SteamVR?

Also, are you using the Beta version? If so, then try using the normal version.

1 Like

Thanks for the suggestion.

I’ve tried uninstalling/reinstalling SteamVR from Steam, but not using Windows Uninstall. I’ll try that soon and report back.

Insert and unplug the DP connector between the helmet and cable connection. If stuck, press the helmet surface on the upper left of the connection with your finger


Thank you @Miracle! You deserve your name.

Unplugging and re-inserting the DP connector on the headset fixed the problem - I had not even realised it was removable. I had previously removed and reconnected all the connectors at the computer end without success.

Edit: I was fooled into thinking that this was a software problem by the fact that system sounds were still audible. So it wasn’t that no signal was getting through to the speakers. It was just that the analogue signal was attenuated by a poor connection, I assume.


Congratulations and enjoy your 8kX

I hope this helps anyone else who has this problem.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.