Any way of recovering serial

i tried piplay 1.1.92 and the headset gives me a red light,and the tool won’t detect it

tried pitool 1.0.2.084,1.0.1.261,1.0.1.263,1.0.1.264 and all worked except for not allowing full 4k (1440p max)
and none gave me the serial

1 Like

No piplay or pitool can give you native 4k. The p4k is only capable of 1080p and 1440p upscaled to 4k. It is one of this model’s limitations due to the mipi bridgechip used.

Strange piplay 192 didn’t work as it was a favorite of many for a very long time.

Have you checked piplay log files and json as it might also be stored there.

If I might ask why are you looking to recover serial number if it is out of warranty? (Just curious)

sorry for the late reply,went for dinner,

haven’t checked the logs yet,is it the same ‘path’ as the pitool?

just want to keep it safe somewhere in case i sell the p4k and the buyer request it or try to scam me (never opened it,still have the original warranty sticker in it),

also i’m obsessive over little things like this (i like to keep things complete with serial,stickers, even if i could find the box and the cleaning cloth again i’d be happy)

1 Like

Hey no worries. Replies can be slow from both sides and ppl need to eat. :beers::wink::+1::sparkles:

Yeah that’s understandable.

Not sure if pitool logs might have it or not. But think maybe piplay might. It’s been awhile. Both programs have logs in there install directory or sub directory.

1 Like

well s***,something bugged on my headset now,one side is darker and the other has a bunch of stripes on it




checked piplay ‘error.log’ and it keeps saying :

Nov 20, 2020 10:24:04 PM com.pi.piextend.z a
INFO: re connecting…
Nov 20, 2020 10:24:08 PM com.pi.piextend.z a
INFO: re connecting…
Nov 20, 2020 10:24:08 PM com.pi.piextend.z a
INFO: NULL reachable local IP is found!
Nov 20, 2020 10:24:09 PM com.pi.piextend.z a
INFO: Task get Connnection From Service!
java.net.SocketException: Socket is not connected
at java.net.Socket.getOutputStream(Unknown Source)
at com.pi.pimanager.piServiceManager.b(Unknown Source)
at com.pi.pictl.pim.j(Unknown Source)
at com.pi.pictl.aH$a.run(Unknown Source)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I’m not sure, but perhaps generating a system report in steamVR can provide similar information.
At least it usually contains comprehensive information on both the headset and the controllers.
This is done while SteamVR is running:
image

if the numbers on “Device 1 - Headset Pimax 4K Pimax VR, Inc.” are the serial then many thanks,i just found it (i dont know if it is the serial,it have 14 numbers - 10071173004350 - )

1 Like

now i’m just bugged out by the vertical lines on the headset,really dont want to remove the warranty sticker to see the problem

Glad you found it :beer:

The vertical stripes are heating threads, most likely. And they must pass when it heats up.

welp,something is wrong with the 4k now,the ‘stripes’ went away but now its darker on both eyes,if i go crazy (back and forth) on the backlight slide it gets darker and darker,then bright all of sudden and fades to dark mode again

hey Ryleth
If you need any technical support, please contact customer service and submit a ticket they will do that for you.
https://support.pimax.com/en/support/tickets/new
Sincerely

1 Like

soo,anyone knows what this darkening is?its really getting in the way of gaming and other thing sice its removing colors and covering things

If it is flickering it might be the automatic defogger/demister. But not sure what might be causing it. As it should briefly flicker and return to normal. The p4k uses just 1 lcd panel vs other headsets that typically have 2.

Have you tried filing a ticket as @miracle recommended?

its a flickering just in one place/vertical line to the right (hard to explain since cant post videos here), it only appears when moving the hmd/head

i’m more concerned now about the darkening in the image,its darkening everything i see a lot,cant see some colors since it appears like a red sepia/warmer tone, the backlight slide seems to work a bit then it darkens again,

yes,already filled a ticket,awaiting an answer there

you guys know how long does it take for the support to answer?

@Miracle can likely look into your ticket number.

ticket #10240,

also,does anyone know the fix for the ghosting in the sn100 series?it wasn’t answered on the previous topic,mine has a lot of ghosting as well(decided to ignore it)

2 Likes

Ghosting is unfortunately no known fix. It seems to be a property of the 4k sharp panel. Sony in the original Xperia 4k phone disabled VR for that reason.

I found in games like Ethan Carter VR using the controller more vs head movements reduces it.

Interestingly though Unity Chan Rockstar demo is quite decent with it.

i play games like falloutvr,skyrimvr,elite dangerous,runes… so the ghosting gets in the way sometimes but nothing serious,

the darkening thats happening now however is preventing me from playing since can’t see some things ingame,dark areas/shadows are pitch black,white lights/paints/colors are yellowed ,yellow lights/color is more brownish

already tried editing the brightness and contrast slides but the image in the hmd only gets whiter/weirder color and illegible when messing with those so apparently brightness/color via software isn’t the issue

1 Like

uhh, this looks like a defective panel caused by an loose contact or similar, the darkness may be related to that.

For the flickering you should check out the hdmi cable. Reducing the frequency or resolution might also do the trick since its most likely caused by bandwidth limits(as far as i know, the 4k uses hdmi 1.4 or 1.4 a which are pretty limited). Cleaning the HDMI Port might also help a bit (also please dont use DVI-D just to mention it)

The Ghosting is very bad i agree, ive tried much to get it better but the only way i could actually improve it a bit was by setting the headset into video mode (with Pitool 2) and then manually editing its attributes using Custom Resolution Utility. But i wouldn’t recommend that methode since it gets very diff very soon

1 Like