8KX setup help - PiTool won't see headset

Hi my 8KX arrived today courtesy of DHL. Box arrived nicely packed and no signs of damage.

I did a clean install of the latest PiTool (no previous version has been installed on my PC since I last did a fresh clean install of Windows 10) and I downloaded the latest 8KX firmware.

Loading PiTool my 8KX is showing as Disconnected - despite being plugged into my one of the DisplayPorts GFX card and two USB 3 ports on my mobo. The red light is on on the headset itself so it’s for sure got power. When I click on Guide it won’t let me click on “Next” when selecting either USB or power cable.

I’ve tried swapping both the DisplayPort and USBs to alternate ports on my GFX card and mobo but that doesn’t seem to make a difference.

Can’t see a way to update the Pimax firmware in PiTool (at least not without getting PiTool to see the headset first).

What’s wrong???

Can you post your system specs?

Try to uninstall pitool, remove the 6 pitool and Pimax folders.

Turn of your pc and connect the headset.

Turn on your pc and install newest pitool and when pitool is running -> Turn on the headset and wait a Little bit.

Check your lighthouses!

BR Henry

1 Like

Make sure this service is running. pi_server.exe

If it’s bright red the headset might just be in standby mode.

Did You try to press the power button?

Also, did You try to unplug both USB connections and connect then both again while the PC is running?

If using extension cables try without them. The X is more picky than the 5K+/8K as it basically maxes out the DP bandwidth.

Lastly, did You try to restart the service from within PiTool?



You may first try to tips provided from the community.
If it doesn’t resolve the issue, please submit a ticket at our helpdesk.
Our technician will provide assistance to you.



Hi all,

I think I’ve fixed it - I believe it was a driver problem with my USB controllers.

I reset Windows and reinstalled PiTool and it recognised the headset. I also managed (I think) to successfully update the firmware but that process is NOT intuitive (as I had to download a separate program to PiTool and then copy/paste those files into the Runtime folder for PiTool. It would be much better if that process could be integrated into PiTool itself (it even seems to have a function for it, but it doesn’t appear to do anything).

Only had time to briefly try out the Apollo 11 HD experience (native resolution, normal FOV) and I was impressed - no discernible screen door effect. I’m looking forward to trying some proper games when I have time at the weekend.

One thing I will say is that the headset strap can definitely be improved upon - I’m hoping they take the feedback on board (from many places) when they finalise the DMAS design.

Also does anyone else find that they get a little bit of light entry at the sides of the headset - no matter which face cushion they use? It’s a minor annoyance but interested to know if anyone has a solution (other than just clamping the headstrap on even tighter - as that’s likely to get uncomfortable after a while).


The DMAS in theory will still use the Bass MAS with the bmr off ear modules.

Those of us whom ordered tge DMAS will receive the modul when fully released.

One thing that can improve the MAS other than proper hinges. Is the sude pads and rear pad can be replaced or augmented with thicker padding

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.