8kx firmware update status?

does anyone know the status of new firmware for the newer (dmas/2001) 8kx?

currently I only have the option to run at 90Hz.

One of the newer pitools has a test firnwarw 2002 that has been reported by some with other refresh rates and possibly upscale mode working.

I picked up my 8KX DMAS headset from FedEx yesterday. I installed Pitool 277 and my new 8kx already had the 2001 firmware with only 90hz installed.

But I am having issues with my single Basestation 2.0 constantly losing tracking. So I decided to install the beta Pitool 279.

I recommend to first fully uninstall older Pitool and also search & delete ALL old pitool remnants from directories in your C drive dirs like user, appdata, program data etc. as there are lots of files left behind that can cause problems. I found them myself but I saw a post with a batch file to do just that on these forums somewhere ?

Please Pimax engineers, integrate a good uninstaller into the pitool software package that totally removes every last Pitool config and reference file. It will save much trouble for all users and your support staff. @PimaxQuorra @PimaxVR @PimaxUSA

The 279 pitool installed fully & updated my Firmware quickly and cleanly. I tested the upscaled 110hz mode plus the native 90hz and 75hz. I like the 75hz because it feels very stable and I can achieve higher frames & gfx settings in Automobilista 2 which requires parallel projection.

Unfortunately I cannot solve my tracking problem which is a concern as using only the internal gyroscope is making me motion sick :face_vomiting::tired_face::crazy_face:

There is also a 280 beta but I think just for 5K Super. Good luck ! :slightly_smiling_face:


I would try pitool 280 as it likely has undocumented fixes from the last 3 pitool releases.

At this time best to consider all pitool releases Beta or Alpha as it has been a very long time since there has been truly a stable release.


Hello :
You might try pitool 280, compared to 277, pitool280 adds the following features:

1. Improved Sword controller compatibility

2. Improved forced firmware update stability
Avoid the headset stuck in DFU mode.

3. Bug fixes for partially 8KX headsets not displaying 60/75HZ and Upscale Mode

4. Additional bug fixes and optimizations.

5. Added one-click recommended settings feature for 5K Super.
(This showed only if you were using 1050/1650 graphics cards.)


1 Like

No option to choose when to update new firmware?


Did you try to reposition the base station at other angle and height?

In addition, I advise filing up a ticket with our tech support, who is ready to look at the tracking issue.

I’ve put this to my notes and review it with the team at our next meeting.



Thank you for you interest and assistance, it is very much appreciated :slight_smile:

Yes I have now positioned my Basestation 2.0 at 2.10 metre height and 2.20 metres distance at a 45 Degree angle diagonally from where my HMD is positioned while I sit in my Racing Sim Rig. I am now doing some testing in game to check integrity of Basestation whether disconnects continue or are now stable tracked.

I also took opportunity to cleanly uninstall Pitool version 277 and now updated with 280 beta. It only updates Pitool software files and there is no Firmware update as the version 279 already successfully update my 8KX DMAS Firmware 2001 to version 2002.

So far results are good with no disconnects but then this did happen well for me also this morning for some time before the disconnects began to happen again. I am hopeful that now with added height, distance and angle this may be the solution ! I will report back after further testing.

Oh and I very much like the Sound stage presented by the DMAS, yes the Bass is not so strong but the crispness and fidelity otherwise is very nice … I am experiencing soundFX in Automobilista 2 while racing that I had never heard before when using my Reverb G2 and I do believe this new version has exceeded the quality of the G2 … some people may be skeptical but I can only believe my own ears. Also Pimax kindly included a set of over ear cups to use with the DMAS like the ones on KDMAS but I yet to test them. Cheers.
Thanks :slight_smile:


Just came back to say that I have been using Pitool 280 for past days and it is working really well. I have had a couple of times the PC totally freezes and locks up requiring a Reboot by turning power off/on again. This has happened when I have changed from Native to Upscaled resolution one time and two times when changing refresh rate from 75 hz to 90 and vice versa. Also once going to 60hz but then I could not get 60 hz to work. I just went back to 75 hz which for me is best on my AMD cpu 5900X with RTX 3090 as it gives me good framerate in my race sims, especially Automobilista2 which requires parallel projection. It would be awesome if Pimax implemented a version of OpenXR at base level code as it is so efficient.

My tracking problems seem to be sorted as they were directly related to the motion hardware I run and the EMI RFI was interfering with the Pimax tracking to the Basestation 2.0. Installed some clipon Ferrite cores to the Pimax usb cables as well as the Motion servo controller cable and touch wood I have had not further disconnects. Lighthouse_Console does throw a Data Error, out of range but I have sent some screenshots of that ouput to Support (Irving I think) who is looking into it so hopefully that is an easy fix !?



Good to hear that man.

This will undoubtedly bring some excitement to the community if an OpenXR is released.

Irving will submit the error to the software team and hopefully it is an easy fix.


The team should consult @mbucchia as he is an xr dev and has already made impressive efforts in making a pimax openxr runtime.


Hey Dan,

Indeed, he’s one of the best in developing XR, Esther may have already contacted him.


Hello everyone.

I recently bought an 8KX DMAS with FW 255.2001. and I only see the 90Hz option in Pitool 277.

Reading this thread I decided to install Pitool 280 and it jumped a firmware update that did not finish correctly leaving the HMD blocked. That scared me.

Fortunately I was able to cleanly uninstall everything and reinstall Pitool 277 and everything is as before but at 90Hz. I dare not try with Pitool 279.

Will it take long for a stable version to come out that gives us 60/75/120Hz?

For my hardware, 120Hz with 60fps reprojection would be fantastic.


1 Like

I bought 8KX DMAS couple months ago. I had the same firmware pre installed as you.

I installed v279 pitool on the 1st day and had no problems as it auto updated the firmware and gave 60, 75 & 90 hz. For sim racing I stick with 75hz which I find rock solid and optimal on my system, very smooth. I was careful to kill all unnecessary background tasks & apps that were running, including my Malwarebytes anti virus software, before installing pitool.

About a week later I totally uninstalled v279 and installed v280 and it worked perfectly. From memory v280 uses same firmware as v279 so it only updated the software component of Pitool. Perhaps you can follow the same path that worked flawlessly for me.

1 Like

Hello Blanes.

I plucked up the courage and followed your advice. I have installed Pitool 279 and now it works. The FW has been updated to 255.2002 and I can apply the frequencies 75 and 60Hz in native mode and 110Hz in upscaling mode.

Now waiting for the possibility of native 120Hz with a new FW.

Many thanks.

1 Like

That’s great, you got it working.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.