8KX complete mess after installing last pitool 272 and last fw 299

Issue Title:
Hi, so after the stupid idea of downloading and installing the last pitool and fw found on pimax site my 8kx became a complete mess, it turns now at 25 fps on virtual desktop, a huge loss of fps.
I uninstalled all and reinstalled the previous versions used , pitool 271 and fw 298 wich use to work great with all settings maxed but now the loss of fps persists.
Any ideas?

HMD Model:
First 3 Numbers Serial:
Pitool Version:
HMD Firmware:

System Info

  • Windows Version:
  • CPU:
  • RAM:
  • Motherboard:
  • GPU Model:
  • GPU Driver:
  • SteamVR Version:
  • Oculus Version:

Attachments (Pics/Video etc…)

1 Like


With Pitool272, you shall try to flash the firmware provided in this thread.

Aside from that, if you have created a service ticket with our TechSupport, our technician should be releasing a debug firmware to fix your problem.


Could you please check so you dont have Compulsive Smooth mode enabled in Pitool? (probably at 1/3 mode because you say its running in 25fps)
Try to disable Compulsive Smooth, click apply. Your framerate should go back to normal again.

Compulsive Smooth is a new mode to lock the framerate at 1/2 or 1/3 of your refreshrate, so in your case I assume you run in 75Hz mode and 1/3 Compulsive mode. Use this mode only if you intend to lock your max framerate to 25fps or 37.5fps at 75Hz, or 30fps or 45fps at 90Hz. Otherwise, just disable it.

Also, just to be sure, disable Smart Smoothing if enabled.


Hi SweViver, old Pimax user here, allready tryed all this. The bad thing is that even reinstalling the previous used pitool and FW which use to work great two days ago, the 8KX works BAD now.
I have a High-end PC with RTX 3090, i9 9900, 48 giga RAM, system use for flightsim, it was working great on steam , for example Virtual desktop pimax Experience setting was supersampling2, normal FOV, Steam SS 500 and everything was fluid on 75Hz Native. Now, despite reinstalling the previous config which used to work great, I get 28-29 FPS on Virtual desktop and I cant even start Warthunder.


Ok I see. Since you reverted back to the old FW and PiTool without any improvement, I suspect the issue is somewhere else.

Personally I would start by checking the GPU performance in normal 2D mode. Start any of your GPU heavy pancake games and see if framerates are still the same. If you are using Afterburner or any overclockning software, make sure they are all set correctly as before.
Also double check so the CPU is not being heavily utilized by any background application.
If all works well in 2D and your GPU boost near/above 2000Mhz, then we are all fine and we can continue to troubleshoot.

Secondly, update to latest Nvidia drivers and reset the settings in the Nvidia control panel. There are many things that potentially can screw up the performance in there. On default, it should work as normal.

Next, try resetting the settings in PiTool and also in SteamVR to check whether your config file has messed up something. SteamVR has a habit to all of a sudden use a different config file (steamvr.vrsettings)
There are 2 locations it can be at:
C:\Program Files (x86)\Steam\config\steamvr.vrsettings
Out of nowhere, especially after a SteamVR update, SteamVR can suddenly decide to use the first OR the second, completely changing your settings. Makes no sense, but its always been like this, ever since OpenVR was introduced into SteamVR.
Either way, check both files and see if there is anything weird in there.

In PiTool, disable Parallel Projection (at least for Virtual Desktop its not needed), Smart Smoothing and especially the Compulsive Smooth if anything is still on.

Now, after doing this, check the outputted SteamVR resolution (at PiTool 1.0 and SteamVR SS 100%). Does it look correct for your 8KX at Normal FOV?

If it is, then just start any random Steam VR game like Beat Saber, Half Life Alyx or Skyrim with PiTool 1.0, SteamVR 100% and confirm they all work fine and as expected. If they do, then start increasing your settings to desired results.

I think this is a good start to make sure nether the GPU, CPU, the drivers, the Nvidia control panel, overclocking software or SteamVR/PiTool settings are doing something weird in your case, since you are saying the framerate is very low.

Try it and let me know how it goes.

But theres one thing that doesnt add up for me:

So we have very similar setups, except for the 9900 and my Ryzen 5950X (which barely makes any difference in normal VR games). Now, as I understand, previously you were using PiTool at 2.0 (I assume thats what you mean with supersampling 2), Normal FOV and SteamVR SS at 500%?

Wow, that must be a resolution of 16K or probably much above. PiTool 2.0 on its own is a crazy high resolution even at SteamVR SS 100%.

I kind of suspect the settings you think were previously used (when it worked) were actually not applied correctly. Now, all of a sudden these settings did apply somehow and you see Virtual Desktop running in 25fps. After all, I wouldnt even expect 25fps using such a high resolution to begin with.

Either way, start with the basic settings (as I said above) and see where it goes from there, and if you can find your optimal settings again giving you a full frame rate. Remember that increasing SteamVR SuperSampling from 100% to 500% while being in Virtual Desktop, wont be applied until you restart Virtual Desktop.

Try all this now and lets see what happens…


Ha ha, thanks man, didn’t have to go further than step 1, it was my GPU. I did a stress test with Kombustor and for some reason my GPU was stuck at 360Mhz. I changed the different OC on the Afterburner and finally the GPU took off. Now you can see in the pics below how my system works. Thanks again


I would go further in this case. Whenever I have a suspected driver issue, I recommend uninstalling the nVidia drivers, rebooting, and installing the new drivers without nVidia Experience and with the “clean install” setting checked. Once installed, display the nVidia Control Panel > Manage 3D Settings page and tweak as desired. Also, if you have made previous changes, say on the Change Resolution page, you will need to update those settings too.


If You’re going for a clean install there’s a tool for that (DDU):

This cleans any leftovers.

That said, I rarely find a need for it… :wink:


Thats great to hear, glad we sorted it out so quickly! :slight_smile:
Ive done this a few times as well actually, having several profiles in Afterburner, I forgot to change to my gaming profile, and got panic when framerate was super low because of the clocks not going further than 800Mhz :stuck_out_tongue:

By the way, nice overclock on the VRAM memory, my 3090 cant handle +1000Mhz it seems.
Ive noticed you dont go over 100% power limit, is there any reason for that? I use to max it out (around 470W at max on the GPU), and it lets me overclock the core a bit more. Not on the memory though.

Totally agree! Clean install is the way to go - every time!


@SweViver @PimaxQuorra @PimaxUSA

I have made this little guide to installation , perhaps this helps someone
please tell me if this procedure for setup is Ok

Normally would be:

  1. Base stations oriented and on, index controllers charged
  2. HMD connected to the PC at DP one
  3. PC ON
  4. Firewall and antivirus OFF
  5. Download Pitool, installation Pitool
  6. HMD ON
  7. Execution Pitool
  8. With Hmd recognized the first time Pitool should automatically upgrade firmware
    if this not happens solve eventually 10500/10600 errors and
    upgrade firmware from pitool or with DFU.EXE
  9. If you have Base stations flashing blu change the channel of one
  10. Pairing Index controllers from Pitool
  11. Room set up from pitool (Optional : only if you have Oculus Games)
  12. Execute steam: (Steam see you have headset and install steam vr)
  13. Execute SteamVR
  14. Put inside SteamVR HMD OFF and Gamepads OFF at NEVER
  15. Execute in SteamVR Room Setup
  16. Put ON Firewall and Antivirus
  17. Inside Pitool make settings valid for all games
  18. Inside Pitool Check and eventually Import games
  19. Inside Pitool Execute Pimax Experience
  20. Inside windows 10 Strenghen Smas Volume
  21. Wear HMD
  22. Regulate IPD
  23. Inside Pimax Experience adjust advanced settings
  25. if you have double vision exit and set PARALLEL PROJECTIONS ON for that game- Restart Game

I am completely new to VR ; so i have some questions:

A) I would like to know if pitool 272 download and auto install Pimax Experience
B) I have not found a discussion about this: Let’s say i have the base stations at 4 meters from each other and they are 2 meters high : i do not want to move in the room, put myself on the floor ect .
to establish tracking what is better at 15) inside steam vr : room scale or standing Only option to have better tracking of headset, arms, hands etc
C) I have 3080 ti . So i believe only pitool 271/fw 298 or pitool 272/fw299 are ok for me. Is this correct ?
D) Pitool 272 what i have to do to have a clean setup ? Someone have said to use DFU.EXE before executing Pitool 272 to avoid auto install of the firmware. Is this correct ? Remember that i have a new headset
E) How much time for a new firmware for Pitool 272 ?

Waiting an answer
Thank you

Actually I don’t have to touch this, it goes up to 127% without asking my permission :wink:


You need to click the download button showed up in the Pitool. And it will pop up a prompt update to latest PE Version.

Base Stations should be above head height (at least 6.5 feet / 2 meters), angled down by 30-45 degrees, positioned no more than 16 feet / 5 meters apart , and place opposite one another in separate corners of the play area.
This will provide you a 5M x 5M room-scale play areas.


We discovered that the auto-updated firmware may contain bugs. You may need to manually flash the firmware using DFU.exe.
If you are unfamiliar with the procedure, please read this article or submit a service ticket to our technical support.

There is no set time frame for this.


Thank you ,
I have installed Pitool 271
My Headset came with FW 290
This pitool do not make an auto update firmware
So, I manually flashed later Firmware 298 alfa with success

For now, I am using 466.77 this graphic driver because is the first for 3080 Ti
and support last dlc of No Man Sky

Pitool 271 imported well all 10 games and they are on Drive D while pitool is on drive C

I solved a VC missing issue.
Repair in this version of 271 alfa do not work because point to DX11
Then I have used a link found in Pitool Support → Knoledge base → Getting started
→ Missing dx item and VC Item

However now i have a new question to continue my setup

Opening later a new Topic " PITOOL 271 one BS is Blu the other is grey"

1 Like