8k+ will not connect with AMD 6700 xt

Upgraded from a 1080ti which worked fine to AMD 6700 xt now whatever I try it always gives me a red light and disconnected plugin HDMI/DP error. Have tried swapping all ports and restarting PC, uninstalling all Pimax software and removing all settings folders nothing works. Has anyone got a AMD 6000 series working here? Thanks

To make things weirder, I can get the headset to turn on with green light but it’s recognised as a secondary monitor and I can see a mouse moving around but still shows disconnected in Pimax!

1 Like

Some of the folks in this thread might have some ideas.


If you haven’t try different DP and Usbs as my 5k+ on my 1080ti doesn’t like the same port I use for the 8k and 8kX.

Also check Diagnose in pitool hlp tab.

Thanks, I’ll have a read through. Yes tried both Display ports (other 2 are HDMI) and tried all the USB slots. Opened a ticket anyway, weird cos it works as a normal display except its upside down and flipped in both eyes

1 Like

Maybe ping some folks in that Amd 90hz thread as they might have some ideas.

It seems to be reading as a display instead of special display.

You might also need to use a driver uninstall to ensure the 1080ti hasn’t left somethings behind and try a fresh install of pitool.

1 Like

Thanks, I tried reinstalling and removing all settings folders and the debug firmware pimax sent me didnt work either. I commented on that thread though thanks for the tip.

1 Like

Well it was a simple solution after all, just had to disable my Nvidia card in Device Manager. Won’t be able to mine on that card when in VR now that’s all.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.