5k+ no longer powers on, 10500 error, power led flashes red once then off [SOLVED]


I received my Pimax 5k+ full kit recently.
When I first set it up I was able to pair everything through PiTool setup: 2x knuckle controllers, 2x 2.0 base stations and the 5k+ hmd.
I did not specifically set up in SteamVR yet, but had downloaded it.
I was able to first get into an open area (mountains in the distance and a moon or sun).
Then a room to look around.
Looking around and moving hands etc worked from what I could tell.

It was disconnecting a after a few minutes, I would re-plug/restart PiTool and headset and try again.
Again it worked for a few minutes.
I clicked the error in PiTool after one of the disconnects and it started what looked liked a firmware update. The bar reached the end but it said failed.

Now when I connect everything I get disconnected 10500 error.


  • I am in Australia for reference, order and shipping were fine.
  • PiTool version v2020.3.24
  • Pimax 5k+ 144hz SN
  • 2x knuckle controller
  • 2x 2.0 base stations
  • Travel adapter on the power adapter (I was provided the wrong adapter (US?) power instead of Australian). This was working initially.
  • GPU: 1080ti, latest updates
  • CPU: AMD Ryzen 7 1800x


  • Headset power LED, when initially plugged into power, flashes red then stays off (black).
  • USB is recognised on some usb ports but not others.
  • Volume control works via usb when in a working port.
  • dfu.exe does not detect the HMD to flash (running from program files)

PiTool lists:

  • Application integrity: Incomplete: Please reinstall
  • USB: Disconnected
  • HDMI/DP: Disconnected
  • LHR undetected
  • Abnormal calibration data
  • Locator detection not found

I have tried:

  • Swapping display ports
  • Different usb ports
  • Different versions of PiTool (the non special edition)
  • Restarting PiTool Service
  • Restarting HMD through PiTool
  • Clearing AppData & Program files for anything related to PiTool/Pimax/openvr and reinstalling PiTool/SteamVR
  • Full shutdown and restart computer
  • Leaving over night, trying again next day
  • Trying without light houses plugged in
  • Trying without Steam/SteamVR open

Any assistance or pointers would be much appreciated.

Thank you,

1 Like

Sorry to hear that, and that’s a pretty comprehensive list of things you have tried. If it is indeed a firmware failure update that has bricked it, I believe there are a couple of tools that can fix it.

However, I haven’t had this problem so I haven’t resorted to either of them myself. Might be safer to wait until some others come online with better experience to help out, but here’s the links:




I hope that helps, good luck!


Thanks for the prompt reply, I appreciate it.
I’ve had a read through the topics you listed and tried some things that haven’t unfortunately worked.

I’ve tried running the third party flasher (as admin) but it has not been able to detect the headset.


I made sure the processes for PiTool and related were closed

None of the usb devices are sitting in DFU mode, nor are there any lights flashing on the headset

The usb does make a “connected” sound when plugged in.

The SN for the headset begins with 204, for future reference, I know that had impact on which firmware to use.

I’m not too sure how to use the official flasher tool found here:

And as such have not tried yet.
I’m not too optimistic on that one seeing as the prior tool was unable to detect the headset at all.

I’ll have another try when I get up tomorrow.

I’m more than happy to try any further suggestions, or if anyone thinks I have done a step incorrectly please let me know.


1 Like

Np at all, right OK that’s a shame. I’m sure you’ll get some further assistance on here shortly, and if all else fails Pimax Support will be able to assist you further. I won’t ping on here just yet, but Pimax Quorra will be able to connect you to the right support team.

1 Like

Hi JoshC,
Just a suggestion, did you try to unplug and reseat the HMD cable at the HMD end?
The only other thing I can suggest is the power adapter may be at fault. there should be a light on, either red, green, purple or red/green/blue cycle.


Hi cruser_icu, thanks for the reply.

I’ve just had a go at reseating the cord on the HMD end but no dice unfortunately.
I don’t mind picking up a power adapter to test, do you know what kind?
I understand that it needs to be 12v with at least 2 amps, but do you know what size the connector needs to be to connect to the HMD cable? I’ve been having a hard time finding the exact size.


1 Like

Here’s some pics from my UK one for 5k+, although the connectors to the headset are presumably universal. 3mm in width.

Sorry if it’s blurry, my phone doesn’t focus too well on it

If no luck, I suggest @PimaxQuorra can help further :+1:


its a 3.5mm diameter plug


I just bought a random universal power supply.

It’s a pretty standard plug size.


Yep, thanks all.
I’ve ordered a universal power supply that should be arriving in the next few days. Hopefully that’ll get me to the power-on stage and I can see what state the firmware is at.


Hi All,

New power supply has come in, same issue unfortunately.
When connected to power the led will flash red once then turn off.
Here’s a quick video, this is when I plug in the power.

Headset is plugged in via usb and display port as well
Any ideas, am I missing something simple?


1 Like

I would file a support ticket if you haven’t already.

1 Like

Thank you for the suggestion, I have just gone and created a ticket on the Pimax support website.
I’ll keep trying things in the meantime.

Does anyone know if there is supposed to be a specific device named and showing up in device manager if everything is working correctly?
I can see the usb audio coming up when plugged in but not sure what I’m looking for regarding the headset - everything looks like a generic device.


1 Like

Check can also this thread , I had you problem and fixed it.


Hi Yata_PL, thanks for the reply.

I have tried just about every usb port but had no luck.
In the process however I decided to try getting the device into dfu mode via the power button combination have had some level of success there.
I have been able to get the device into dfu mode.

Using one of the flasher tools I have tried applying the newest firmware.
It “succeeded” then started rebooting which is when I received an error with the usb being unrecognised. Flasher tool still thinks it is rebooting.

Power LED is now a solid red (progress at least!)

I will wait a little longer in case it’s a time thing before trying again.
Might also try another usb port as well, as suggested.


Different method, says success still but headset now stuck with a solid red LED and 10500 error.
Tried both the latest manual firmware and the firmware from Pitool p2.dfu.



Hi all,

Happy to report that support were able to fix the issue for me via remote session.
From what I understand they applied firmware update, checked a few things with their tool, we then reinstalled Pitools and some restarts of the headset and it is working.
A few adjustments to where I have my base stations and I’ll be smooth sailing.

Thanks for everyone’s help, it was much appreciated.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.