5K+: Connected-disconnected-connected-disconnected....etc

Hi There,

Due to circomstances, I was not able to use the Pimax 5K+ a lot. Lately, I’ve picked it up again.
Currently running into some major issues. :frowning:
When connecting the Pimax and starting the PiTool I constantly get this cycle of connected-disconnected-connected-disconnected with different error-codes (10500, 10632, 10932, 10532, 20000, 10510, 10514). 10500 being the most common one.
It’s doing this while the HMD is sitting on my PC, not being touched at all!
It will also not ‘see’ the Vive Base stations (v1.0).

I’ve reinstalled the Firmware using Sweviver’s tutorial with no result.

Running a Nvidia 1070 (Asus Strix, latest drivers), AMD 1700 and 16GB of RAM, Windows 10 (Professional) with the latest PiTool.

Does anyone else have this problem? Or perhaps a solution?

1 Like

Make sure your base stations are still mode b and c … but I think that is more of a solution for not tracked problem

1 Like

I would say that problem is mostly related to usb, try different USB ports and remember to upgrade the usb drivers.

@Heliosurge wasn’t there a motherboard that had usb problems, asus I don’t remember the chipset.?


What does Diagnose say under help?

Majority of Trouble codes points to an issue with USB connection.

As mentioned try different USB ports. I have Asus Strix RGB b450-I (itx) with r7 2700x with 1080ti with 16g ram

Is your Nvidia Driver up to date? And have you ran Nvidia Firmware to update DP1.4 features?

Ensure USB drivers BiOS & chipset drivers updated from Asus Website.

Check Taskmanager for Piserver(s) AntiVirus may also be interfering.


Don’t know if it helps but you could try this:
Create a new .txt file with windows editor and insert the code below.

    del /q /s “C:\ProgramData\pimax\runtime\config\lighthouse”
    rmdir /q /s “C:\ProgramData\pimax\runtime\config\lighthouse”
    sc stop PiServiceLauncher && timeout 1 && sc start PiServiceLauncher

Then save it as .bat and run the .bat file as administrator with your Pimax connected and PiTool open. And make sure, that you installed PiTool in „C:\ProgramData“ otherwise you have to insert your specific location. Sometimes I get tracking issues, then I run this file and voila everything works again.


Which version of PiTool are you running (beta or non-beta)? PiTool v121 and v129 (betas) both addressed some issues that were causing disconnects.

1 Like

Also had similar problems. Initially I had a defective 5k+. There it wasn’t on-off-on-off… but more on-for-twenty-seconds - then off for an hour or so. Reproducible with several computers and on all USB-ports.

Got a replacement 5k+. Initially it worked great, then it showed the on-off-on-off[repeat] behavior you describe. The problem disappeared when I used another USB-port (even though the one I had it plugged in worked for months without problems before).
Could be related to a combination of PiTool version and USB-port - or more likely other stuff that shares the same internal USB port with the external USB port the HMD is connected to. (Often the external ports are just a built-in USB hub, so different USB devices can influence each other).

With newer versions of PiTool also make sure you use the newest graphics card drivers. The first time I tried one of the new Brainwarp-enabled betas the HMD didn’t even turn on (LED stayed all-red). Turned out to be a graphics card driver issue, had to upgrade.

Also ensure that your cable is plugged in properly on the HMD side (it can be removed with some force and thus get loose even if it doesn’t look like it on first sight).

Best way to rule this out is to disconnect all other USB devices and try one port after the other. If this doesn’t work up- or downgrade PiTool and the graphics card driver, check the cables etc. If this still doesn’t work and you have to opportunity to repeat the test with another computer - do that. If this still leads to the same results your HMD might be defective. Then best write a ticket with everything you already tried (to shorten the procedure).

1 Like

Tom if you haven’t be sure to dowwnload Nvidia Firmware Bios update. It gives 10 series cards dp 1.4 functions. Another user @mhl153 fixed his connectivity.


Thanks for the tip about the firmware, @Heliosurge - looks like my 1080 needed it.